OSPF Configuration (Single Area)


















Make a habit of always going through this check list before configuring any routing protocol on your devic
  • Before configuring any routing protocol always check if all the interfaces where you’re going to configure something are up and running.
  • Also check what other routing protocols are already configured on the router
There might be another instance of the same routing protocol already running on the device or there might be some policies conflicting with the configuration you’re going to make
  •   You should always know what impact your configurations are going to have on your network
  • If possible always apply configurations in a lab environment before implementing in live environment
  • Always check Routing table before and after configuring routing protocols to check what impact your routing protocol have on your routing table
  • When configuring in live environment never save the configuration before making sure everything is working fine and as expected after you made configurations



Configuring loopback interfaces for Router ID


R1(config)#interface loopback 1
*Nov 24 17:15:38.975: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#ip address 10.10.10.10 255.255.255.0
R1(config-if)#exit

R2(config)#interface loopback 1
*Nov 24 17:17:55.415: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R2(config-if)#ip address 20.20.20.20 255.255.255.0
R2(config-if)#exit

R3(config)#interface loopback 1
*Nov 24 17:19:17.687: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R3(config-if)#ip address 30.30.30.30 255.255.255.0
R3(config-if)#exit


Verifying Interface Status


 R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.10.1     YES NVRAM  up                    up     
FastEthernet0/1            unassigned      YES NVRAM  administratively down down   
Serial1/0                  1.1.1.1         YES NVRAM  up                    up     
Serial1/1                  unassigned      YES manual administratively down down   
Serial1/2                  unassigned      YES NVRAM  administratively down down   
Serial1/3                  unassigned      YES NVRAM  administratively down down   
Loopback1                  10.10.10.10     YES manual up                    up     

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.20.1     YES NVRAM  up                    up     
FastEthernet0/1            unassigned      YES NVRAM  administratively down down   
Serial1/0                  1.1.1.2         YES NVRAM  up                    up     
Serial1/1                  2.1.1.1         YES NVRAM  up                    up     
Serial1/2                  unassigned      YES NVRAM  administratively down down   
Serial1/3                  unassigned      YES NVRAM  administratively down down   
Loopback1                  20.20.20.20     YES manual up                    up     

R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.30.1     YES NVRAM  up                    up     
FastEthernet0/1            unassigned      YES NVRAM  administratively down down   
Serial1/0                  unassigned      YES manual administratively down down   
Serial1/1                  2.1.1.2         YES NVRAM  up                    up     
Serial1/2                  unassigned      YES NVRAM  administratively down down   
Serial1/3                  unassigned      YES NVRAM  administratively down down   
Loopback1                  30.30.30.30     YES manual up                    up 


Verifying Routing Protocols Configured


R1#show ip protocols
R1#

R2#show ip protocols
R2#

R3#show ip protocols
R3#

It means that there’s no routing protocol already configured.

Configuring Routing Protocol

R1#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router ospf 1
R1(config-router)#network 172.16.10.0 0.0.0.255 a 0
R1(config-router)#network 1.1.1.0 0.0.0.255 a 0
R1(config-router)#exit
*Nov 24 14:42:32.843: %SYS-5-CONFIG_I: Configured from console by console

R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 1
R2(config-router)#network 172.16.20.1 0.0.0.255 area 0
R2(config-router)#network 1.1.1.0 0.0.0.255 area 0
*Nov 24 14:46:59.747: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.1 on Serial1/0 from LOADING to FULL, Loading Done
R2(config-router)#network 2.1.1.0 0.0.0.255 area 0
R2(config-router)#exit

You can see that the adjacency between R2 and R1, where configuration has already been made is up and it is in FULL state.


R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 1
R3(config-router)#network 172.16.30.0 0.0.0.255 area 0
R3(config-router)#network 2.1.1.0 0.0.0.255 area 0
*Nov 24 14:54:46.767: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.20.1 on Serial1/1 from LOADING to FULL, Loading Done
R3(config-router)#exit

Now another adjacency is up and running between R3 and R2


Verifying the adjacencies


R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.20.1       0   FULL/  -        00:00:38    1.1.1.2         Serial1/0

On R1 Neighbor 172.16.20.1 is up and it’s in full state


R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.30.1       0   FULL/  -        00:00:39    2.1.1.2         Serial1/1
172.16.10.1       0   FULL/  -        00:00:30    1.1.1.1         Serial1/0

R2 has two neighbors because it is in the middle of other two routers and they are directly connected to R2


R3#show ip ospf  neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.20.1       0   FULL/  -        00:00:39    2.1.1.1         Serial1/1

R3 has only one directly connected neighbor and it is in full state


Write your routing table with your own hands before checking it on the router


Checking the routing table


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       *****OUTPUT omitted Intentionally*****
      
Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.1.1.0 [110/128] via 1.1.1.2, 00:22:51, Serial1/0
     172.16.0.0/24 is subnetted, 3 subnets
O       172.16.30.0 [110/129] via 1.1.1.2, 00:22:51, Serial1/0
O       172.16.20.0 [110/65] via 1.1.1.2, 00:22:51, Serial1/0
C       172.16.10.0 is directly connected, FastEthernet0/0


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       *****OUTPUT omitted Intentionally*****

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.1.1.0 is directly connected, Serial1/1
     172.16.0.0/24 is subnetted, 3 subnets
O       172.16.30.0 [110/65] via 2.1.1.2, 01:17:29, Serial1/1
C       172.16.20.0 is directly connected, FastEthernet0/0
O       172.16.10.0 [110/65] via 1.1.1.1, 01:18:47, Serial1/0

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       *****OUTPUT omitted Intentionally*****

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/128] via 2.1.1.1, 01:18:00, Serial1/1
     2.0.0.0/24 is subnetted, 1 subnets
C       2.1.1.0 is directly connected, Serial1/1
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.30.0 is directly connected, FastEthernet0/0
O       172.16.20.0 [110/65] via 2.1.1.1, 01:18:00, Serial1/1
O       172.16.10.0 [110/129] via 2.1.1.1, 01:18:00, Serial1/1

Convergence is already completed all the routers have all the networks in the routing table so we can test the connectivity with Ping test.

Verifying connectivity with ping test

R1#ping 172.16.30.1 source 172.16.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.10.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/27/56 ms

R3#ping 172.16.20.1 source 172.16.30.1    

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.30.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/52 ms


If you’re using loopback interface as your router ID it’s highly recommended to advertise router ID, for management purpose Router ID should be reachable throughout the network, if a network is down Routing protocol will route you from another path.



Post a Comment

0 Comments